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1. Download and Install EAGLE, available free from http://www.cadsoftusa.com/, which makes circuit 

boards 

a. The following files should be downloaded 

i. [eagle-4.xx.exe]   Circuit Board Program 

ii. [manual-eng.pdf]  Documentation 

iii. [tutorial-eng.pdf]  Documentation 

b. The following restrictions apply to the free Light Edition of Eagle 

i. Board area is restricted to 100 x 80 mm (about 3.9 x 3.2 inches) 

ii. Only two signal layers can be used 

iii. A schematic can consist of only one single sheet 

2. Download and Install ViewMate, available free from 

http://www.pentalogix.com/Download/download.html, which allows viewing of circuit board Gerber files.  

Gerber files are files that are sent to the Board house to manufacture the circuit boards.  The board 

displayed on the computer screen by Eagle is not necessarily what you get.  The Gerber file viewer will 

show the manufactured board. 

3. Open New Project 

a. Start Eagle software.  In Control Panel window, go to File => New => Project 

b. The name of the project will default to New_Project_x, where x is the number of the project.   

4. Create a Schematic 

a. In Control Panel, highlight New_Project_x and go to File => New => Schematic 

b. Save the schematic, File => Save, for the first time and give it a name 

c. Select the Control Panel window and notice that the new schematic is now under the project folder 

5. Set the Grid 

a. In the schematic window, go to View => Grid 

b. Select  

i. Display => On; Style => Dots;  

ii. Size => 0.05 in.; Multiple => 1; Alt => .025 in. 

c. Parts will now snap to the grid of .05 inch.  However, in the event that a smaller movement is 

needed for part placement, depressing the Alt key will allow movements of .025 inch. 

6. Make Available the Libraries 

a. In command line at top of schematic page, type:    use  *  <enter> 

b. This command makes available for use all part libraries 
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7. Change Text Font Always to Vector Type 

a. Always use Vector type font for text.  The Vector type font is the only one that reproduces on the 

manufactured board according to what you see on the computer screen.  The Gerber viewer 

program called ViewMate is designed to view the manufactured board according to the files 

generated by Eagle.   

b. In the schematic page, go to Options => User interface => check Always vector font.   

8. Adding a Frame in the Schematic Window; Grouping and Moving 

a. A Frame is a page size outline with a document information box in the corner. 

b. In the schematic window, Edit => Add; in the search window at the bottom, type frame; select 

Letter_L; then OK. 

c. After placing Frame into schematic, press <Esc> <Esc> to exit the Add tool. 

d. To move the frame, select the Move tool; Edit => Move.  Then select the Frame and move cursor.  

The Document Information box in the Frame will need to be moved also.  Move frame so that 

lower left hand corner is placed on the large cross, which is the coordinate 0,0. 

e. Use View => Zoom to Fit to center the view on the screen. 

f. As an alternative to moving the frame and document information box separately, they can be 

“grouped” together and moved as a unit.  To move the Frame and the Document Information box 

together, group them. 

i. Edit  => Group to select the grouping tool. 

ii. Using cursor, drag a box around the Frame and box to select them as a group 

iii. Select the Move tool.  Notice the instruction in the lower left-hand corner of the window.  

“Left-click to select object to move (right-click to move group”.  Right-click to move the 

group. 

9. Drawing the Schematic -- Adding Parts 

a. Assuming that we are designing a 555 timer in astable mode to blink an LED.  The circuit requires 

1-555 timer, 3 resistors, 2 capacitors, and one LED. 

b. Place a 555 timer, resistors, and capacitors on the sheet 

i. Edit  => Add 

1. In the search box at the bottom, type in *555 to search for any combination of 

terms with 555 in it. 

2. Select TIMER, then OK.  Click OK to place the part in the schematic and use 

<Esc> <Esc> to quit. 

ii. To add a resistors, capacitors use the rcl.lib;  for the LED,  the  led.lib. 

1. Edit  => Add to bring up the libraries 

2. The libraries for the previous search of the 555 timer will be shown.  To restore 

the view of all the libraries, clear the search box and press <Enter>.   

3. Click the “+” on rcl.lib  to drop down the menu. 
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4. Select the RESUS-10 (name my be different).  This is a resistor with U.S. 

symbols and holes that are 10 mm apart.  Select OK and place, with each click 

of the mouse, as many as you need.  Use right-click of the mouse to rotate the 

part.  <Esc> to quit. 

5. In the rcl.lib, look for ELC-2.5L.  This is an electrolytic capacitor with leads that 

are 2.5 mm apart.  Use this capacitor for the 2.2 uF. Use a CAP-7.5 for the 0.01 

uF capacitor. 

6. In the led.lib, look for LED5MM and select Add.  LED stands for Light Emitting 

Diode. 

c. Delete, Rotate, Mirror, Copy, Move, etc. as needed using the drop down Edit menu. 

d. When using a multiple package IC, such as a TL072 op amp, there are two op amps in a package.  

They will be placed, for example, as IC1A and IC1B.  The power supply pins can be added using 

the "Invoke" command from the Edit menu 

10. Draw the Power Supply Sources 

a. In the Control Window, Library, select battery.lbr.  Choose AB9V and add to schematic. 

b. To connect the power supply and grounds, use a symbol instead of “wiring” them together. 

i. In the Control Panel, go to supply2.lbr and select +9V.  This is a symbol that, when 

attached to pins, will automatically be common to all without the need for wiring. 

ii. Attach the +9V symbol to the positive side of the battery and to all connections that are 

common to that.  Use right-click of the mouse to rotate part as needed.  Place the +9V 

symbol at the tip of the battery terminal marked +.  An error will result later if it overlaps. 

iii. In supply2.lib, select GND and place on the negative side of the battery and to all 

connections that are grounded (ground symbol         ). 

11. Wiring the Schematic Diagram 

a. Use Draw => Net to make the wiring connections.  (Do not use the wire command for wiring.)  Be 

sure not to overlap the lines when connecting to parts. 

12. Assign Values to the Parts and Change Name if Needed 

a. Use Edit => Value and select the part.  Fill in the window with desired value 

b. Use Edit => Name and select the part.  Fill in the window with desired name change. 

13. Check for Errors When Schematic is Finished 

a. Use Tools => Erc.  (One warning will usually show regarding the power supply.) 

b. Check the Control Panel window and notice that an *.erc file has been created which denotes 

errors and warnings, if any, in the schematic design. 

14. Fill in your name in the document box 

a. Use Draw => Text and place text in document box.  

b. Use Edit => Change Size => .1 and select text to resize.
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HOW TO MAKE DOUBLE-SIDED CIRCUIT BOARDS II 

15. Generate the Board From the Schematic 

a. To generate the board, go to File => Switch to board; answer Yes to message. 

b. In newly created Board window, group components and drag into rectangle.  The rectangle is the 

new circuit board size. 

c. Move and rotate components as desired.  

i. Notice that each part has a cross somewhere.  This is used for selecting that part for 

moving, deleting, etc.  

ii. The parts value and name move with the component.  To separate the name from the 

component in order to move it separately, use the Edit => Smash tool.  The name can be 

moved independent of the part.  To undo, use the <shift> key while “smashing”. 

iii. Leave at least two grid spaces (100mil) from edge board to component or text. 

iv. Leave at least two grid spaces (100mil) between pads when placing components. 

d. Resize the circuit board using Move command by selecting the sides of the rectangle.  Keep 

100mil from any pads or text. 

e. While moving the components, notice that the “rubber-banding” also moves.  Usually a better 

rubber-band route exists.  Use Tools => Ratsnest to rearrange the rubber-banding to the shortest 

distances. 

16. Measure Between Two Points 

a. Use this to measure the size of the board or distance between parts. 

b. The cross on the screen show the absolute coordinates 0,0.  Use View => Mark to place a relative 

0,0 coordinate as point 1 anywhere.  Then move cursor to anywhere point 2 and notice the relative 

coordinates in command line.  The “R” values are the x,y distance from point 1 and the “P” values 

are the polar coordinates from point 1.   

17. Define Signal Classes 

a. Traces should be sized according to manufacturers specs and Ampacities.  Create different signal 

classes and define sizes and spacing using Net Classes. 

i. Minimum trace size and Ampacity: (300mA, 10mils); (400mA, 15mils); (700mA, 

20mils); (1 Amp, 25mils); (2 Amp, 50mils); (4 Amp, 100mils). 

ii. Preferred minimum trace width, 15 mils.  Use this as the default size.  Some Board 

houses can manufacture traces down to 8 mils, if needed. 

iii. Preferred minimum spacing between traces and parts, 15 mils.  Use this as the default.  

Spacing can be as small as 8 mils for some Board houses. 

b. In the Schematic window, go to Edit => Net classes to create the classes of signals.     

i. For Number 0, always leave name as Default and set Width = 15mil; Clearance = 15mil.  

These specs will then apply to all traces that are undefined in subsequent Net classes. 

ii. Number 1, we can arbitrarily name this Power, Width = 20 mil, Clearance = 15mil. 

iii. Number 2, we can arbitrarily name this Ground, Width = 25 mil, Clearance = 15 mil. 
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18. Assign Signal Class to Traces 

a. Select the tool, Edit => Change => Class; select number 1, Power.   

b. Click the cursor on the rubber-band that is connected to the plus side of the battery, which we will 

define as Power.  After clicking, nothing seems to happen, but it and all instances of the rubber-

banding connected to this are now defined as Power and will have traces and clearances according 

to the definitions created earlier in the Net classes. 

c. To verify the class properties of the rubber-band, select View => Info.  Now select the rubber-band 

that was selected as Power.  A window will show the properties indicating the net class = Power.  

The width is still 0 because the traces have not been laid yet.  Click other traces other than Power 

while in Info mode and note that they are Class = 0 default. 

d. Select the class for Ground (same as (a) above) and select one rubber-band that is connected to the 

minus side as the battery which we will define as Ground.  All instances of Ground now inherit the 

width and clearance defined in Net classes.  Use View => Info to verify that the class Ground has 

been assigned. 

19. Create Board Traces 

a. To create traces from the rubber-banding (ratsnest) use Tools => Auto => OK.  

b. To undo traces and restore the ratsnest, select all the traces using the Group tool.  Then use the 

Edit => Ripup tool.  (Remember to right-click to ripup the group – see instructions in command 

line in lower left of screen) 

c. After creating traces, verify trace widths using View => Info. 

d. Check trace destinations.  Use View => Show which will highlight an individual trace in its 

entirety.  The trace connection points can be verified for correctness. 

e. As a final check, run a Design Rule Check.  Instead of default settings, use supplied file PCB-

POOL.dru.  Change location in Control Panel (Options => Directories).  From the circuit board 

screen activate (Use Tools => Drc => OK.  In the lower left-hand corner of the screen it should 

read “DRC: No errors”. 

20. Place Text on Board – the Silkscreen Layer 

a. Before writing text on the board, the silkscreen layer must be chosen as the destination layer for 

the text. 

b. Edit => Change => Layer; select tPlace for the top of the board silkscreen (recommended) or 

choose bPlace for the bottom of the board silkscreen.  Click OK. 

c. Very important:  Change the font type to Vector.  This is the only font that displays correctly 

between the computer image and the output file.  Edit => Change => Font => Vector. 

d. The text must not cover the pads, since these are solder points.  Covering traces is OK. 

e. Create the text.  Draw => Text.  Right-click to rotate if needed when placing text. 

f. To change size of text, Edit => Change => Size, select size and click cursor on the cross of the 

text. 

g. To check the size, font and layer of text, use View => Info and click cursor on the cross of the text. 

h. To delete text, use Edit => Delete. 
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21. Create Gerber Files and Drilling Data 

a. The Gerber and Drilling data files are the files necessary for the Board house to manufacture the 

boards. 

b. To create Gerber files, go to the Control Panel.  Expand and select CAM Jobs => gerb274x.cam.   

c. When the CAM window appears, in that window go to File => Open => Board, select the current 

board being worked on, and Open.   

d. In the CAM window, select the Silk screen CMP tab.  The silkscreen will print the layers that are 

enabled in the chart on the right.  Enable by clicking the number layer for Dimension, tPlace, 

tName, tValue.  This will print the board outline (Dimension), top of board text (tPlace), top of 

board component names (tName), and top of board component values (tValue).  If (silkscreenJ) 

text was placed on bottom of board, enable the bPlace layer, otherwise do not enable it. 

e. Create files.  Select Process Job.  Close CAM window.  The Gerber files have been created and 

are listed in the Control Panel under the Project. 

f. Create preliminary Drilling Data file.  In the Control Panel, expand the User Language Programs.  

Right-click on drillcfg.ulp, select Run in Board => Inch => OK => OK => Save.  This is the 

preliminary process that is required before actually generating the drilling data.  A *.drl file has 

now been created in the Project menu. 

g. Create Drilling Data file.  In the Control Panel, expand and double-click CAM Jobs => 

excellon.cam.  When the excellon window appears, select in that window File => Open => Board, 

select the board, then Open.  Next, select Process Job and close.  All the drilling data files have 

now been created and are listed in the Control Panel under the Project. 

22. Check Output Files With Gerber Viewer (ViewMate) 

a. Start the program called ViewMate.exe.  Viemate is a “gerber file viewer”.   A black slate appears.   

b. Open Eagle and place Eagle and Viewmate windows side by side.  Display the Eagle Project files.  

Drag and drop the *.cmp, *.plc, *.sol, *.stc, and *.sts files one at a time onto the ViewMate black 

slate.  The resulting view in each case is what the Board house will be manufacturing.   

i. *.cmp is the component side.   

ii. *.plc is the silkscreen for component side 

iii. *.sol is the solder side 

iv. *.stc is the soldering mask for the component side 

v. *.sts is the soldering mask for the solder side 

c. Check for obvious irregularities, like traces too close, text overrun outside the board border, etc.  

The most common error is text overrun due to not selecting the Vector type font.  Make changes 

by starting up Eagle and going through the board procedure again. 

d. When done, close ViewMate. 
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23. Prepare Files To Be Sent to the Board House 

a. Create a README.txt file with the following information for the Board house. 

i. Your name, address, phone number, email 

ii. Name of Project 

iii. Number of boards desired 

iv. Thickness of board: 62mils (the Gerber files do not specify a board thickness and this 

value is typical) 

b. If the board house accepts *.brd files, simply attach that file and include the readme.txt 

information.  Upon your request, the board house will send you an estimate to produce the boards. 

c. If the board house does not accept *.brd files directly, zip all the Eagle project files and the 

README.txt file into one zip file.  Send the zip file to the Board house of your choice for an 

estimate.  The Board house does not need all the Eagle files in the Project, but to be on the safe 

side, send them all (*.brd, *.cmp, *.drd, *.dri, *.drl, *.erc, *.gpi, *.plc, *.pro, *.sch, *.sol, *.stc, 

*.stc, *.sts, README.txt) as one zipped file. 

24. Board House 

a. PCB-Pool www.pcb-pool.com 
i. The only manufacturer that will take multiple board designs and only charge for one set 

up.  Excellent prices 
b. Advanced Circuits, www.4pcb.com  http://www.4pcb.com/  

i. Good rates for students: $33 per board, no minimum. Look under Specials -> Student 
Discount.   Boards must be sent to a University.   

c. Sierra Proto Express www.protoexpress.com 
i. I’ve used the following Board house with very good results.  Fast turnaround time, 

excellent quality boards, reasonably good prices.    
d. Custom PCB http://www.custompcb.com 

1. Lowest cost I’ve seen.  
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